svn commit: r333995 - head/sys/teken

Bruce Evans brde at optusnet.com.au
Tue May 22 01:18:27 UTC 2018


On Mon, 21 May 2018, [UTF-8] Jean-Sébastien Pédron wrote:

> Log:
>  teken: Rename the "Set Cursor Style" sequence to match vt100.net docs
>
>  This fixes inconsistencies with the rest of the `sequences` file.
>
>  No functional changes.
>
>  Requested by:	ed
> 
> Modified: head/sys/teken/sequences
> ==============================================================================
> --- head/sys/teken/sequences	Mon May 21 20:23:04 2018	(r333994)
> +++ head/sys/teken/sequences	Mon May 21 20:35:16 2018	(r333995)
> @@ -48,7 +48,7 @@ CUF	Cursor Forward				^[ [ a		n
> CUP	Cursor Position				^[ [ H		n n
> CUP	Cursor Position				^[ [ f		n n
> CUU	Cursor Up				^[ [ A		n
> -CS	Cursor style				^[ [ SP q	r
> +DECSCUSR	Set Cursor Style		^[ [ SP q	r
> DA1	Primary Device Attributes		^[ [ c		r
> DA2	Secondary Device Attributes		^[ [ > c	r
> DC	Delete character			^[ [ P		n

Any chance of keeping this file sorted?

DECSCUSR is a verbose yet cryptic abbreviation which is not even expanded
its name.  It is the only abbreviation longer than 7 characters.  This messes
up the souce formatting.

Not expanding DEC in the name is normal, but other letters are normally
expanded.  I don't know what USR is.  It looks like a bad abbreviation
for "user".  'S' in it might mean style.

> Modified: head/sys/teken/teken_subr.h
> ==============================================================================
> --- head/sys/teken/teken_subr.h	Mon May 21 20:23:04 2018	(r333994)
> +++ head/sys/teken/teken_subr.h	Mon May 21 20:35:16 2018	(r333995)
> @@ -372,7 +372,7 @@ teken_subr_cursor_up(teken_t *t, unsigned int nrows)
> }
>
> static void
> -teken_subr_cursor_style(teken_t *t, unsigned int style)
> +teken_subr_set_cursor_style(teken_t *t, unsigned int style)
> {
>
> 	/* TODO */

Names must be chosen carefully since they become function names which tend
to be long and ugly.  This one is not long but is a bit to generic.  The
worst function name double_height_double_width_line_bottom() has one of
the best abbreviations (DECDHL).  DEC is mercifully not spelled out in the
function name, and Double Width Bottom is omitted from the abbreviation.

Bruce


More information about the svn-src-head mailing list