svn commit: r312998 - in head/sys/modules: . hwpmc_mips24k hwpmc_mips74k

Adrian Chadd adrian at FreeBSD.org
Mon Jan 30 22:29:23 UTC 2017


Author: adrian
Date: Mon Jan 30 22:29:21 2017
New Revision: 312998
URL: https://svnweb.freebsd.org/changeset/base/312998

Log:
  [mips] add some (temporary, I hope!) mips24k/mips74k hwpmc modules.
  
  Ideally we'd have a top level hwpmc module with the shared bits, then
  cpu specific glue as needed.  However, on the MIPS side, there's no
  probe code - {mips24k, mips74k, octeon} implement a set of methods
  that hwpmc_mips.c expects.
  
  So this populates separate modules with duplicate code.
  Ew, but it does work.
  
  This gets me off the hook - these work fine as copied into the relevant
  mfsroot for mips24k/mips74k systems.
  
  TODO:
  
  * do it the "right" way in the future.  Note that modules/hwpmc/ does
    build fine on MIPS, it jusn't DO anything.  So it'd be nice to
    maybe call that "hwpmc_core" and then "hwpmc" can be the CPU/arch glue.

Added:
  head/sys/modules/hwpmc_mips24k/
  head/sys/modules/hwpmc_mips24k/Makefile   (contents, props changed)
  head/sys/modules/hwpmc_mips74k/
  head/sys/modules/hwpmc_mips74k/Makefile   (contents, props changed)
Modified:
  head/sys/modules/Makefile

Modified: head/sys/modules/Makefile
==============================================================================
--- head/sys/modules/Makefile	Mon Jan 30 22:11:53 2017	(r312997)
+++ head/sys/modules/Makefile	Mon Jan 30 22:29:21 2017	(r312998)
@@ -138,6 +138,8 @@ SUBDIR=	\
 	${_hptnr} \
 	${_hptrr} \
 	hwpmc \
+	${_hwpmc_mips24k} \
+	${_hwpmc_mips74k} \
 	${_hyperv} \
 	i2c \
         ${_ibcore} \
@@ -520,6 +522,11 @@ _cxgbe=		cxgbe
 SUBDIR+=	zfs
 .endif
 
+.if ${MACHINE_CPUARCH} == "mips"
+	_hwpmc_mips24k=	hwpmc_mips24k
+	_hwpmc_mips74k=	hwpmc_mips74k
+.endif
+
 .if ${MACHINE_CPUARCH} != "aarch64" && ${MACHINE_CPUARCH} != "arm" && \
 	${MACHINE_CPUARCH} != "mips" && ${MACHINE_CPUARCH} != "powerpc" && \
 	${MACHINE_CPUARCH} != "riscv"

Added: head/sys/modules/hwpmc_mips24k/Makefile
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/sys/modules/hwpmc_mips24k/Makefile	Mon Jan 30 22:29:21 2017	(r312998)
@@ -0,0 +1,14 @@
+#
+# $FreeBSD$
+#
+
+.PATH: ${.CURDIR}/../../dev/hwpmc
+
+KMOD=	hwpmc_mips24k
+
+SRCS=	hwpmc_mod.c hwpmc_logging.c hwpmc_soft.c vnode_if.h
+SRCS+=	hwpmc_mips.c
+
+SRCS+=	hwpmc_mips24k.c
+
+.include <bsd.kmod.mk>

Added: head/sys/modules/hwpmc_mips74k/Makefile
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/sys/modules/hwpmc_mips74k/Makefile	Mon Jan 30 22:29:21 2017	(r312998)
@@ -0,0 +1,14 @@
+#
+# $FreeBSD$
+#
+
+.PATH: ${.CURDIR}/../../dev/hwpmc
+
+KMOD=	hwpmc_mips74k
+
+SRCS=	hwpmc_mod.c hwpmc_logging.c hwpmc_soft.c vnode_if.h
+SRCS+=	hwpmc_mips.c
+
+SRCS+=	hwpmc_mips74k.c
+
+.include <bsd.kmod.mk>


More information about the svn-src-head mailing list