svn commit: r287188 - head/sys/powerpc/powerpc

Justin Hibbits jhibbits at FreeBSD.org
Thu Aug 27 03:44:07 UTC 2015


Author: jhibbits
Date: Thu Aug 27 03:44:06 2015
New Revision: 287188
URL: https://svnweb.freebsd.org/changeset/base/287188

Log:
  Use the macro definition for EXC_PGM_TRAP, instead of the magic number.

Modified:
  head/sys/powerpc/powerpc/trap.c

Modified: head/sys/powerpc/powerpc/trap.c
==============================================================================
--- head/sys/powerpc/powerpc/trap.c	Thu Aug 27 02:59:48 2015	(r287187)
+++ head/sys/powerpc/powerpc/trap.c	Thu Aug 27 03:44:06 2015	(r287188)
@@ -815,7 +815,7 @@ db_trap_glue(struct trapframe *frame)
 	    && (frame->exc == EXC_TRC || frame->exc == EXC_RUNMODETRC
 #ifdef AIM
 		|| (frame->exc == EXC_PGM
-		    && (frame->srr1 & 0x20000))
+		    && (frame->srr1 & EXC_PGM_TRAP))
 #else
 		|| (frame->exc == EXC_DEBUG)
 #endif
@@ -827,7 +827,7 @@ db_trap_glue(struct trapframe *frame)
 		if (*(uint32_t *)frame->srr0 == EXC_DTRACE)
 			return (0);
 #ifdef AIM
-		if (type == EXC_PGM && (frame->srr1 & 0x20000)) {
+		if (type == EXC_PGM && (frame->srr1 & EXC_PGM_TRAP)) {
 #else
 		if (frame->cpu.booke.esr & ESR_PTR) {
 #endif


More information about the svn-src-head mailing list