svn commit: r249047 - head/sys/cddl/contrib/opensolaris/uts/common/fs/zfs

Andriy Gapon avg at FreeBSD.org
Wed Apr 3 11:06:27 UTC 2013


Author: avg
Date: Wed Apr  3 11:06:26 2013
New Revision: 249047
URL: http://svnweb.freebsd.org/changeset/base/249047

Log:
  spa_open_common: fix argument to zvol_create_minors
  
  Prior to r248571 spa_open was always called with a bare pool name,
  but now it is called with a dataset name instead (spa_lookup handles
  that).
  So, when a ZFS root is mounted spa_open is called with a name of a root
  dataset, which can very well be different from the pool name.
  But zvol_create_minors should be called with the pool name, because it
  performs a recursive traversal of all datasets under the name to find
  all those that are volumes.
  
  MFC after:	7 days

Modified:
  head/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/spa.c

Modified: head/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/spa.c
==============================================================================
--- head/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/spa.c	Wed Apr  3 11:00:50 2013	(r249046)
+++ head/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/spa.c	Wed Apr  3 11:06:26 2013	(r249047)
@@ -2885,7 +2885,7 @@ spa_open_common(const char *pool, spa_t 
 #ifdef __FreeBSD__
 #ifdef _KERNEL
 		if (firstopen)
-			zvol_create_minors(pool);
+			zvol_create_minors(spa->spa_name);
 #endif
 #endif
 	}


More information about the svn-src-head mailing list