svn commit: r188918 - head/sys/dev/ata/chipsets

Gavin Atkinson gavin at FreeBSD.org
Mon Feb 23 00:15:09 PST 2009


On Sun, 22 Feb 2009, Alexander Motin wrote:

> Author: mav
> Date: Sun Feb 22 14:08:20 2009
> New Revision: 188918
> URL: http://svn.freebsd.org/changeset/base/188918
>
> Log:
>  Tune AHCI verbose messages to make log more readable.
>
[snip]
> @@ -665,9 +670,10 @@ ata_ahci_softreset(device_t dev, int por
>     //ctp->cfis[7] = ATA_D_LBA | ATA_D_IBM;
>     ctp->cfis[15] = (ATA_A_4BIT | ATA_A_RESET);
>
> -    if (ata_ahci_issue_cmd(dev, ATA_AHCI_CMD_RESET | ATA_AHCI_CMD_CLR_BUSY,100))
> -	device_printf(dev, "setting SRST failed ??\n");
> -	//return -1;
> +    if (ata_ahci_issue_cmd(dev, ATA_AHCI_CMD_RESET | ATA_AHCI_CMD_CLR_BUSY,100)) {
> +	device_printf(dev, "software reset set timeout\n");
> +	return (-1);
> +    }
>

Was the uncommenting of the return intentional here?  Before, the code 
would continue to clear the soft reset even if it didn't appear to have 
worked.

> @@ -767,11 +778,11 @@ ata_ahci_reset(device_t dev)
> 	break;
>     default: /* SOS XXX */
> 	if (bootverbose)
> -	    device_printf(dev, "No signature, asuming disk device\n");
> +	    device_printf(dev, "Unknown signature, asuming disk device\n");
> 	ch->devices = ATA_ATA_MASTER;
>     }

Spelling is wrong here (and was before you changed it too): should be 
"assuming" not "asuming"

Gavin


More information about the svn-src-head mailing list