svn commit: r186603 - head/sys/kern

Robert Watson rwatson at FreeBSD.org
Tue Dec 30 16:09:58 UTC 2008


Author: rwatson
Date: Tue Dec 30 16:09:57 2008
New Revision: 186603
URL: http://svn.freebsd.org/changeset/base/186603

Log:
  Rename mbcnt to mbcnt_delta in uipc_send() -- unlike other local
  variables named mbcnt in uipc_usrreq.c, this instance is a delta
  rather than a cache of sb_mbcnt.
  
  MFC after:	3 weeks

Modified:
  head/sys/kern/uipc_usrreq.c

Modified: head/sys/kern/uipc_usrreq.c
==============================================================================
--- head/sys/kern/uipc_usrreq.c	Tue Dec 30 16:00:36 2008	(r186602)
+++ head/sys/kern/uipc_usrreq.c	Tue Dec 30 16:09:57 2008	(r186603)
@@ -754,7 +754,7 @@ uipc_send(struct socket *so, int flags, 
 {
 	struct unpcb *unp, *unp2;
 	struct socket *so2;
-	u_int mbcnt, sbcc;
+	u_int mbcnt_delta, sbcc;
 	u_long newhiwat;
 	int error = 0;
 
@@ -884,7 +884,7 @@ uipc_send(struct socket *so, int flags, 
 				control = NULL;
 		} else
 			sbappend_locked(&so2->so_rcv, m);
-		mbcnt = so2->so_rcv.sb_mbcnt - unp2->unp_mbcnt;
+		mbcnt_delta = so2->so_rcv.sb_mbcnt - unp2->unp_mbcnt;
 		unp2->unp_mbcnt = so2->so_rcv.sb_mbcnt;
 		sbcc = so2->so_rcv.sb_cc;
 		sorwakeup_locked(so2);
@@ -893,7 +893,7 @@ uipc_send(struct socket *so, int flags, 
 		newhiwat = so->so_snd.sb_hiwat - (sbcc - unp2->unp_cc);
 		(void)chgsbsize(so->so_cred->cr_uidinfo, &so->so_snd.sb_hiwat,
 		    newhiwat, RLIM_INFINITY);
-		so->so_snd.sb_mbmax -= mbcnt;
+		so->so_snd.sb_mbmax -= mbcnt_delta;
 		SOCKBUF_UNLOCK(&so->so_snd);
 		unp2->unp_cc = sbcc;
 		UNP_PCB_UNLOCK(unp2);


More information about the svn-src-head mailing list