svn commit: r346423 - head/sys/fs/nfsserver

Rick Macklem rmacklem at FreeBSD.org
Tue Sep 3 14:08:04 UTC 2019


Author: rmacklem
Date: Fri Apr 19 23:27:23 2019
New Revision: 346423
URL: https://svnweb.freebsd.org/changeset/base/346423

Log:
  Replace "vp" with NULL to make the code more readable.
  
  At the time of this nfsv4_sattr() call, "vp == NULL", so this patch doesn't
  change the semantics, but I think it makes the code more readable.
  It also makes it consistent with the nfsv4_sattr() call a few lines above
  this one. Found during code inspection.
  
  MFC after:	2 weeks

Modified:
  head/sys/fs/nfsserver/nfs_nfsdserv.c

Modified: head/sys/fs/nfsserver/nfs_nfsdserv.c
==============================================================================
--- head/sys/fs/nfsserver/nfs_nfsdserv.c	Fri Apr 19 23:04:07 2019	(r346422)
+++ head/sys/fs/nfsserver/nfs_nfsdserv.c	Fri Apr 19 23:27:23 2019	(r346423)
@@ -2886,7 +2886,7 @@ nfsrvd_open(struct nfsrv_descript *nd, __unused int is
 			NFSM_DISSECT(tl, u_int32_t *, NFSX_VERF);
 			cverf[0] = *tl++;
 			cverf[1] = *tl;
-			error = nfsv4_sattr(nd, vp, &nva, &attrbits, aclp, p);
+			error = nfsv4_sattr(nd, NULL, &nva, &attrbits, aclp, p);
 			if (error != 0)
 				goto nfsmout;
 			if (NFSISSET_ATTRBIT(&attrbits,




More information about the svn-src-all mailing list