svn commit: r344690 - head/sys/cddl/contrib/opensolaris/uts/common/fs/zfs

Pawel Jakub Dawidek pjd at FreeBSD.org
Fri Mar 1 05:54:14 UTC 2019


Author: pjd
Date: Fri Mar  1 05:54:13 2019
New Revision: 344690
URL: https://svnweb.freebsd.org/changeset/base/344690

Log:
  Improve readability of the code by making it explicit where the 'c' variable
  starts. It is also more consistent with similar code in this file.

Modified:
  head/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/vdev_raidz.c

Modified: head/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/vdev_raidz.c
==============================================================================
--- head/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/vdev_raidz.c	Fri Mar  1 05:04:29 2019	(r344689)
+++ head/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/vdev_raidz.c	Fri Mar  1 05:54:13 2019	(r344690)
@@ -568,7 +568,7 @@ vdev_raidz_map_alloc(abd_t *abd, uint64_t size, uint64
 			    abd_alloc_linear(rm->rm_col[c].rc_size, B_TRUE);
 		}
 
-		for (off = 0; c < acols; c++) {
+		for (off = 0, c = rm->rm_firstdatacol; c < acols; c++) {
 			rm->rm_col[c].rc_abd = abd_get_offset(abd, off);
 			off += rm->rm_col[c].rc_size;
 		}


More information about the svn-src-all mailing list