svn commit: r350617 - head/sys/kern

Mariusz Zaborski oshogbo at FreeBSD.org
Mon Aug 5 20:31:18 UTC 2019


Author: oshogbo
Date: Mon Aug  5 20:31:17 2019
New Revision: 350617
URL: https://svnweb.freebsd.org/changeset/base/350617

Log:
  procdesc: fix the function name
  
  I changed name of the function r350429 and forgot to update
  the r350612 patch.
  
  Reported by:	jenkins
  MFC after:	1 month

Modified:
  head/sys/kern/sys_procdesc.c

Modified: head/sys/kern/sys_procdesc.c
==============================================================================
--- head/sys/kern/sys_procdesc.c	Mon Aug  5 20:26:01 2019	(r350616)
+++ head/sys/kern/sys_procdesc.c	Mon Aug  5 20:31:17 2019	(r350617)
@@ -419,7 +419,7 @@ procdesc_close(struct file *fp, struct thread *td)
 			if ((p->p_flag & P_TRACED) == 0) {
 				proc_reparent(p, p->p_reaper, true);
 			} else {
-				clear_orphan(p);
+				proc_clear_orphan(p);
 				p->p_oppid = p->p_reaper->p_pid;
 				proc_add_orphan(p, p->p_reaper);
 			}


More information about the svn-src-all mailing list