svn commit: r329609 - head/stand/lua

Kyle Evans kevans at freebsd.org
Mon Feb 19 22:42:08 UTC 2018


On Mon, Feb 19, 2018 at 4:37 PM, Ian Lepore <ian at freebsd.org> wrote:
> On Mon, 2018-02-19 at 22:29 +0000, Kyle Evans wrote:
>>
>> +                       -- Swap the first two menu entries
>> +                       menu_entries[1], menu_entries[2] = menu_entries[2],
>> +                           menu_entries[1];
>>
>
> IMO, this is the sort of unreadable insanity that comes from having
> inflexible rules about line-wrapping which trump readability.  The
> original code could be easily understood.  The suggested replacement,
>
>     menu_entries[1], menu_entries[2] =
>         menu_entries[2], menu_entries[1]
>
> Was also pretty readable, although not as much as it would be if it
> were all on one line.  But splitting the line at the whitespace nearest
> to 80 columns just creates an unreadable mess for the insignificant
> virtue of following some arbitrary rule.  (Which is why I very often
> ignore that rule and split lines at the point < 80 which makes the most
> sense for understanding the code, even if that means splitting at
> column 30.)
>

Right, perhaps we should clarify this while the opportunity is ripe
for style.lua(9) into something more like "80 columns are preferred,
wrapping may occur much earlier than 80 columns." I blindly followed
it here because we hadn't discussed any exception to it previously,
but I think we're more likely in Lua to run into scenarios where the
current guideline just isn't appropriate.


More information about the svn-src-all mailing list