svn commit: r270303 - in head: sys/sys usr.bin/elfdump
Ed Maste
emaste at FreeBSD.org
Thu Aug 21 20:55:11 UTC 2014
Author: emaste
Date: Thu Aug 21 20:55:10 2014
New Revision: 270303
URL: http://svnweb.freebsd.org/changeset/base/270303
Log:
Rename DT_FEATURE_1 to DT_FEATURE
This provides a minor cleanup in elfdump; there are otherwise no
consumers in the tree. Old SUN documentation can be found for either
variant, but GNU binutils switched to DT_FEATURE around 2000.
Sponsored by: The FreeBSD Foundation
Modified:
head/sys/sys/elf_common.h
head/usr.bin/elfdump/elfdump.c
Modified: head/sys/sys/elf_common.h
==============================================================================
--- head/sys/sys/elf_common.h Thu Aug 21 20:36:22 2014 (r270302)
+++ head/sys/sys/elf_common.h Thu Aug 21 20:55:10 2014 (r270303)
@@ -426,7 +426,7 @@ typedef struct {
#define DT_PLTPADSZ 0x6ffffdf9 /* pltpadding size */
#define DT_MOVEENT 0x6ffffdfa /* move table entry size */
#define DT_MOVESZ 0x6ffffdfb /* move table size */
-#define DT_FEATURE_1 0x6ffffdfc /* feature holder */
+#define DT_FEATURE 0x6ffffdfc /* feature holder */
#define DT_POSFLAG_1 0x6ffffdfd /* flags for DT_* entries, effecting */
/* the following DT_* entry. */
/* See DF_P1_* definitions */
Modified: head/usr.bin/elfdump/elfdump.c
==============================================================================
--- head/usr.bin/elfdump/elfdump.c Thu Aug 21 20:36:22 2014 (r270302)
+++ head/usr.bin/elfdump/elfdump.c Thu Aug 21 20:55:10 2014 (r270303)
@@ -213,7 +213,7 @@ d_tags(u_int64_t tag)
case DT_PLTPADSZ: return "DT_PLTPADSZ";
case DT_MOVEENT: return "DT_MOVEENT";
case DT_MOVESZ: return "DT_MOVESZ";
- case 0x6ffffdfc: return "DT_FEATURE";
+ case DT_FEATURE: return "DT_FEATURE";
case DT_POSFLAG_1: return "DT_POSFLAG_1";
case DT_SYMINSZ: return "DT_SYMINSZ";
case DT_SYMINENT : return "DT_SYMINENT (DT_VALRNGHI)";
More information about the svn-src-all
mailing list