svn commit: r269474 - in head: share/man/man4 sys/dev/vt

Bruce Evans brde at
Tue Aug 12 03:18:06 UTC 2014

On Mon, 11 Aug 2014, John Baldwin wrote:

> On Monday, August 04, 2014 8:03:58 pm Bruce Evans wrote:
>> On Mon, 4 Aug 2014, John Baldwin wrote:
>>> I realize the API uses 'SPCL' as an abbreviation, but for user-facing things like a sysctl and tunable, I think it might be better to spell it out as
> "specialkeys" instead?
>> It is a bad name, and also gratuitously different from syscons where the
>> names are:
>>      hw.syscons.kbd_reboot
>>      hw.syscons.kbd_debug
>>      hw.syscons.sc_no_suspend_vtswitch
> I would prefer individual nodes for vt along these lines as I think it is
> clearer to the user ("what exactly constitutes a special key?")

But rename them a bit so it is clearer that they give limited access
control.  The sysctl -d descriptions are no better about this:

% hw.syscons.kbd_reboot: enable keyboard reboot
% hw.syscons.kbd_debug: enable keyboard debug
% hw.syscons.sc_no_suspend_vtswitch: Disable VT switch before suspend.

These also have some style bugs ("enable" is not capitalized; the last
description is terminated).

The option name SC_DISABLE_KDBKEY is better.  It more clearly controls
a key, not debugging.  The option name SC_DISABLE_REBOOT is no better.


More information about the svn-src-all mailing list