svn commit: r212369 - head/usr.sbin/pciconf

John Baldwin jhb at FreeBSD.org
Thu Sep 9 18:29:49 UTC 2010


Author: jhb
Date: Thu Sep  9 18:29:48 2010
New Revision: 212369
URL: http://svn.freebsd.org/changeset/base/212369

Log:
  - Use 'sta' to hold the PCIR_STATUS register value instead of 'cmd' when
    walking the capability list.
  - Use constants for PCI header types instead of magic numbers.
  
  MFC after:	1 week

Modified:
  head/usr.sbin/pciconf/cap.c

Modified: head/usr.sbin/pciconf/cap.c
==============================================================================
--- head/usr.sbin/pciconf/cap.c	Thu Sep  9 18:19:15 2010	(r212368)
+++ head/usr.sbin/pciconf/cap.c	Thu Sep  9 18:29:48 2010	(r212369)
@@ -460,20 +460,20 @@ cap_pciaf(int fd, struct pci_conf *p, ui
 void
 list_caps(int fd, struct pci_conf *p)
 {
-	uint16_t cmd;
+	uint16_t sta;
 	uint8_t ptr, cap;
 
 	/* Are capabilities present for this device? */
-	cmd = read_config(fd, &p->pc_sel, PCIR_STATUS, 2);
-	if (!(cmd & PCIM_STATUS_CAPPRESENT))
+	sta = read_config(fd, &p->pc_sel, PCIR_STATUS, 2);
+	if (!(sta & PCIM_STATUS_CAPPRESENT))
 		return;
 
 	switch (p->pc_hdr & PCIM_HDRTYPE) {
-	case 0:
-	case 1:
+	case PCIM_HDRTYPE_NORMAL:
+	case PCIM_HDRTYPE_BRIDGE:
 		ptr = PCIR_CAP_PTR;
 		break;
-	case 2:
+	case PCIM_HDRTYPE_CARDBUS:
 		ptr = PCIR_CAP_PTR_2;
 		break;
 	default:


More information about the svn-src-all mailing list