svn commit: r191116 - head/sys/kern

Ed Schouten ed at FreeBSD.org
Wed Apr 15 20:15:37 UTC 2009


Author: ed
Date: Wed Apr 15 20:15:36 2009
New Revision: 191116
URL: http://svn.freebsd.org/changeset/base/191116

Log:
  Remove unneeded variable and casting from newdev().
  
  Remove the `udev' variable, which has a different type than the original
  function argument and si_drv0. The `udev' name is also misleading,
  because it is not the number returned by dev2udev(). Rename this
  argument to `unit'. It is the same number as returned by dev2unit().

Modified:
  head/sys/kern/kern_conf.c

Modified: head/sys/kern/kern_conf.c
==============================================================================
--- head/sys/kern/kern_conf.c	Wed Apr 15 20:08:26 2009	(r191115)
+++ head/sys/kern/kern_conf.c	Wed Apr 15 20:15:36 2009	(r191116)
@@ -513,23 +513,21 @@ notify_destroy(struct cdev *dev)
 }
 
 static struct cdev *
-newdev(struct cdevsw *csw, int y, struct cdev *si)
+newdev(struct cdevsw *csw, int unit, struct cdev *si)
 {
 	struct cdev *si2;
-	dev_t	udev;
 
 	mtx_assert(&devmtx, MA_OWNED);
-	udev = y;
 	if (csw->d_flags & D_NEEDMINOR) {
 		/* We may want to return an existing device */
 		LIST_FOREACH(si2, &csw->d_devs, si_list) {
-			if (dev2unit(si2) == udev) {
+			if (dev2unit(si2) == unit) {
 				dev_free_devlocked(si);
 				return (si2);
 			}
 		}
 	}
-	si->si_drv0 = udev;
+	si->si_drv0 = unit;
 	si->si_devsw = csw;
 	LIST_INSERT_HEAD(&csw->d_devs, si, si_list);
 	return (si);


More information about the svn-src-all mailing list