svn commit: r186322 - head/sys/kern

Ed Schouten ed at 80386.nl
Fri Dec 19 15:47:50 UTC 2008


Ivan,

* Ivan Voras <ivoras at FreeBSD.org> wrote:
>   Reviewed by:	ed (older version)

As you mentioned, I didn't review this version. Like I said, I don't
have strong opinions on the subject, but:

> Modified: head/sys/kern/tty.c
> ==============================================================================
> --- head/sys/kern/tty.c	Fri Dec 19 14:47:38 2008	(r186321)
> +++ head/sys/kern/tty.c	Fri Dec 19 14:49:14 2008	(r186322)
> @@ -871,9 +871,9 @@ tty_alloc(struct ttydevsw *tsw, void *sc
>  
>  	tty_init_termios(tp);
>  
> -	cv_init(&tp->t_inwait, "ttyinput");
> -	cv_init(&tp->t_outwait, "ttyoutput");
> -	cv_init(&tp->t_bgwait, "ttybackground");
> +	cv_init(&tp->t_inwait, "ttyinp");
> +	cv_init(&tp->t_outwait, "ttyout");
> +	cv_init(&tp->t_bgwait, "ttybgw");
>  	cv_init(&tp->t_dcdwait, "ttydcd");

If we're renaming them to <=6-character strings, maybe it's better to
use "ttyin" and "ttybg"? The old TTY code used these strings as well.

I've also got a small preference of "ttymtx" over "ttylck". "ttymtx"
makes it more clear it is blocked on the mutex, while "lck" could be
literally any form of locking (file locking?).

-- 
 Ed Schouten <ed at 80386.nl>
 WWW: http://80386.nl/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/svn-src-all/attachments/20081219/ba60fbf1/attachment.pgp


More information about the svn-src-all mailing list