svn commit: r46319 - head/en_US.ISO8859-1/books/porters-handbook/special

Brad Davis brd at FreeBSD.org
Thu Mar 5 21:48:23 UTC 2015


Author: brd
Date: Thu Mar  5 21:48:21 2015
New Revision: 46319
URL: https://svnweb.freebsd.org/changeset/doc/46319

Log:
  Sync up the databases section with reality.
  
  PR:		195549

Modified:
  head/en_US.ISO8859-1/books/porters-handbook/special/chapter.xml

Modified: head/en_US.ISO8859-1/books/porters-handbook/special/chapter.xml
==============================================================================
--- head/en_US.ISO8859-1/books/porters-handbook/special/chapter.xml	Thu Mar  5 21:37:34 2015	(r46318)
+++ head/en_US.ISO8859-1/books/porters-handbook/special/chapter.xml	Thu Mar  5 21:48:21 2015	(r46319)
@@ -4300,35 +4300,39 @@ post-patch:
 	    <entry><varname>USE_BDB</varname></entry>
 	    <entry>If variable is set to <literal>yes</literal>,
 	      add dependency on
-	      <package role="port">databases/db41</package>
-	      port.  The variable may also be set to values: 40, 41,
-	      42, 43, 44, 46, 47, 48, or 51.  It is possible to declare a
-	      range of acceptable values,
-	      <varname>USE_BDB</varname>=42+ will find the highest
-	      installed version, and fall back to 42 if nothing else
-	      is installed.</entry>
+	      <package role="port">databases/db5</package>
+	      port.  The variable may also be set to values: 48, 5
+	      or 6.  It is possible to declare a range of acceptable
+	      values, <varname>USE_BDB</varname>=48+ will find the
+	      highest installed version, and fall back to 4.8 if
+	      nothing else is installed.
+	      <varname>WANT_BDB_VER</varname> will always build this
+	      port with a specific version of the Berkely DB.
+	      <varname>INVALID_BDB_VER</varname> can be used to
+	      specify a version that cannot be used.</entry>
 	  </row>
 
 	  <row>
 	    <entry><varname>USE_MYSQL</varname></entry>
 	    <entry>If the variable is set to <literal>yes</literal>,
 	      add a dependency on the <package
-		role="port">databases/mysql55-client</package> port.
+		role="port">databases/mysql56-client</package> port.
 	      An associated variable,
 	      <varname>WANT_MYSQL_VER</varname>, may be set to
-	      values such as 323, 40, 41, 50, 51, 52, 55, or
-	      60.</entry>
+	      values such as 51, 55, or 60.  Additionally to
+	      specify use of Percona, use 56p, or for MariaDB, use
+	      53m, 55m or 100m.</entry>
 	  </row>
 
 	  <row>
 	    <entry><varname>USE_PGSQL</varname></entry>
 	    <entry>If set to <literal>yes</literal>, add dependency
 	      on <package
-		role="port">databases/postgresql90-client</package>
+		role="port">databases/postgresql93-client</package>
 	      port.  An associated variable,
 	      <varname>WANT_PGSQL_VER</varname>, may be set to
-	      values such as 83, 84, 90, 91 or 92.  It is possible to declare
-	      a minimum or maximum value;
+	      values such as 84, 90, 91, 92, 93 or 94.  It is
+	      possible to declare a minimum or maximum value;
 	      <varname>WANT_PGSQL_VER</varname>= <literal>
 	      90+</literal> will cause the port to depend on a
 	      minimum version of 9.0.</entry>
@@ -4336,11 +4340,11 @@ post-patch:
 
 	  <row>
 	    <entry><varname>USE_SQLITE</varname></entry>
-	    <entry>If variable is set to <literal>yes</literal>, add
+	    <entry>If set to <literal>yes</literal>, add
 	      dependency on
 	      <package role="port">databases/sqlite3</package>
-	      port.  The variable may also be set to values: 3,
-	      2.</entry>
+	      port.  The variable may also be set to 3 or 2, to add
+	      a dependency on 3.x or 2.x, respectively.</entry>
 	  </row>
 	</tbody>
       </tgroup>


More information about the svn-doc-all mailing list