PERFORCE change 165415 for review

Jonathan Anderson jona at FreeBSD.org
Mon Jun 29 18:16:02 UTC 2009


http://perforce.freebsd.org/chv.cgi?CH=165415

Change 165415 by jona at jona-trustedbsd-belle-vmware on 2009/06/29 18:15:58

	Changed names of constants, removed old (and commented-out) constants

Affected files ...

.. //depot/projects/trustedbsd/capabilities/src/tools/cap/user_angel/server.c#13 edit

Differences ...

==== //depot/projects/trustedbsd/capabilities/src/tools/cap/user_angel/server.c#13 (text+ko) ====

@@ -280,14 +280,11 @@
 
 	switch(req)
 	{
-//		case FD_FROM_PATH:
 		case UA_OPEN_PATH:
-			puts("FD_FROM_PATH");
 			return handle_path_request(client);
 
-//		case FD_POWERBOX:
 		case UA_POWERBOX:
-			puts("FD_POWERBOX");
+			puts("UA_POWERBOX");
 			return handle_powerbox_request(client);
 
 		default:
@@ -305,6 +302,8 @@
 	char path[256] = "";
 	unsigned int pathlen = 256;
 
+	printf("UA_OPEN_PATH");
+
 	struct ua_datum *d = ua_recv(client, NULL, &fdlen);
 	if(ua_unmarshall_string(d, path, &pathlen) < 0)
 	{
@@ -313,6 +312,8 @@
 	}
 	free(d);
 
+	printf(": %s\n", path);
+
 	int32_t flags, rights;
 	if(ua_unmarshall_int(ua_recv(client, NULL, NULL), &flags) < 0)
 	{


More information about the p4-projects mailing list