PERFORCE change 105781 for review

Todd Miller millert at FreeBSD.org
Thu Sep 7 13:29:44 UTC 2006


http://perforce.freebsd.org/chv.cgi?CH=105781

Change 105781 by millert at millert_g5tower on 2006/09/07 13:28:20

	Rename mac_modify_task_label() to mac_task_modify_label()
	for consistency with other MAC function names.

Affected files ...

.. //depot/projects/trustedbsd/sedarwin8/darwin/xnu/config/MACFramework.exports#2 edit
.. //depot/projects/trustedbsd/sedarwin8/darwin/xnu/osfmk/kern/task.c#4 edit
.. //depot/projects/trustedbsd/sedarwin8/darwin/xnu/security/mac_mach_internal.h#4 edit

Differences ...

==== //depot/projects/trustedbsd/sedarwin8/darwin/xnu/config/MACFramework.exports#2 (text+ko) ====

@@ -1,7 +1,7 @@
 _mac_policy_register
 _mac_policy_unregister
 _sysctl__security_mac_children
-_mac_modify_task_label
+_mac_task_modify_label
 
 _mac_vnop_getxattr
 _mac_vnop_setxattr

==== //depot/projects/trustedbsd/sedarwin8/darwin/xnu/osfmk/kern/task.c#4 (text+ko) ====

@@ -1699,7 +1699,7 @@
 }
 
 void
-mac_modify_task_label(
+mac_task_modify_label(
 	struct task	*pt,
 	void		*arg,
 	void (*f)	(struct label *l, void *arg))

==== //depot/projects/trustedbsd/sedarwin8/darwin/xnu/security/mac_mach_internal.h#4 (text+ko) ====

@@ -44,7 +44,7 @@
 void mac_task_create(struct task *, struct task *, struct label *,
     struct label *, struct label *);
 void mac_task_create_kernel(struct task *, struct label *, struct label *);
-void mac_modify_task_label( struct task *pt, void *arg,
+void mac_task_modify_label( struct task *pt, void *arg,
     void (*f)(struct label *l, void *arg));
 
 /* ports */


More information about the p4-projects mailing list