Script configure failed unexpectedly

Thomas D. Dean tomdean at
Tue Jun 1 03:35:04 UTC 2021

On 5/31/21 4:17 AM, Jan Beich wrote:
> "Thomas D. Dean" <tomdean at> writes:
>> A new install.  In /usr/ports/x11/xorg.
>>> make
>> ...
>> checking for APPRES... no
>> configure: error: Package requirements (x11 xt xproto >= 7.0.17) were
>> not met:
>> Package 'ice', required by 'xt', not found
>> Package 'sm', required by 'xt', not found
> Looks like a pilot error and doesn't occur on the package cluster.
> x11/appres doesn't use ice (libICE) and sm (libSM) directly but relies
> on x11-toolkits/libXt which specifies ice and sm in its pkg-config file.
> To fix reinstall x11-toolkits/libXt or run "pkg check -d".
>> libX11-1.6.12,1                X11 library
>> libXt-1.2.0,1                  X Toolkit library
>> xorgproto-2020.1               X Window System unified protocol definitions
> Before trying to build anything make sure to upgrade dependencies first.
> If you've installed some packages from /quarterly (default) set then
> switch the ports/ tree from "main" to "2021Q2" branch.
> Alternatively, "pkg install appres" or "pkg install xorg".
I tried the install again - problem with INDEX-13 truncated.
Cksum on Freebsd 13 source OK.
rewrite the usb stick
reinstall Freebsd 13
cd /usr/ports/x11/xorg

This time, it worked.

Sorry for the noise.

More information about the freebsd-x11 mailing list