[Bug 217689] x11-drivers/xf86-video-intel: Panic since latest update

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Fri Mar 10 20:35:01 UTC 2017


            Bug ID: 217689
           Summary: x11-drivers/xf86-video-intel: Panic since latest
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: x11 at FreeBSD.org
          Reporter: bacon4000 at gmail.com
          Assignee: x11 at FreeBSD.org
             Flags: maintainer-feedback?(x11 at FreeBSD.org)

On my Lenovo T61, Intel driver was working well until the latest pkg upgrade.

I had been preloading i915kms out of necessity, from /boot/loader.conf.

System now panics when trying to start Xorg.

Tried moving i915kms load to /etc/rc.conf kms_list="i915kms".  Also tried not
preloading it at all.  Same results in every case.

Here's a skeletal snapshot of the panic:

fbd0 on drm0
VT: Replacing driver "vga" with new "fb"
info [drm] Initialized i915 1.6.0 20080730 for drmn0 on minor 0
drm0: <Intel i965GM> on vgapci0
panic: make_dev_sv bad si_name (error=17, si_name=dri/card0)
#0 ... kdb_backtrace
#15 ... Xfast_syscall+0xfb

Happy to provide more info if needed.

Deleting xf86-video-intel and falling back to vesa eliminates the problem.

You are receiving this mail because:
You are the assignee for the bug.

More information about the freebsd-x11 mailing list