[Bug 217585] graphics/libGL: MESA-LOADER: failed to retrieve device information

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Mon Mar 6 13:45:58 UTC 2017


            Bug ID: 217585
           Summary: graphics/libGL: MESA-LOADER: failed to retrieve device
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: x11 at FreeBSD.org
          Reporter: erisianash at gmail.com
                CC: freebsd-x11 at FreeBSD.org
             Flags: maintainer-feedback?(x11 at FreeBSD.org)
          Assignee: x11 at FreeBSD.org

Created attachment 180560
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=180560&action=edit
glxinfo output

I'm running the drm-next branch on a Lenovo Thinkpad T450s with Intel HD 5500

When testing the CFT for the Xorg 1.18 update gl worked as expected and
modesetting+glamor worked flawlessly, however the Xorg+Mesa update has resulted
in the following:

* X fails to start with the modesetting driver reporting 

MESA-LOADER: failed to retrieve device information
Require OpenGL version 2.1 or later.
Fatal server error:
(EE) AddScreen/ScreenInit failed for driver 0

on the console.

* X starts with the intel driver but glxgears causes the screen to stop
updating (except for the mouse pointer. glxinfo prints the same MESA-LOADER
error and also reports "OpenGL renderer string: Mesa DRI Unknown Intel

I've observed this behavior on drm-next and TrueOS.

You are receiving this mail because:
You are on the CC list for the bug.

More information about the freebsd-x11 mailing list