Some help needed - keyboard does not work after recent update

Milan Obuch freebsd-x11 at
Thu Mar 2 10:22:18 UTC 2017


as part of my update routine I rebuild my system to recent 10-STABLE.
After reboot X did not start. This may be caused by some not yet tested
update in ports installed, so I looked in log files and find some
issues with drivers. In order to clear things I rebuild some ports,
found some help googling for hints and got display to work this way.
Mouse works too, so I can do something to verify I did not screwed my
system badly, but could not find a way to get keyboard working again.

I tried to build X with minimum dependencies, also rebuilt xserver
with no devd nor hal configure backend and did a static configuration.
Autoconfigure did not work for me either - trying to use ati driver
while there is Radeon HD 6290 (Wrestler) seems to not work.

I create minimal 'almost working' configuration by butting module.conf
into /usr/local/etc/X11/xorg.conf.d loading just shadow, fb and
glamoregl modules. This way startx does not complain, X is started, but
keystrokes on keyboard seems to be ignored.

Xorg.0.log is pasted as
it was with no conf backend in xserver, however devd backend does not
changed much.

Are there any flags i can try? I did search for ideas, tried them, but
nothing helped.


More information about the freebsd-x11 mailing list