Strange input device (ukbd/ums) and signal handling problems with X11 on CURRENT

Garrett Cooper yanegomi at
Sun Jan 13 20:05:14 UTC 2013

(Sorry for the cross-post, but this applies to -current and -x11)
    I recently installed CURRENT on my workstation at home again and
I'm running into issues where in X11 it will stop registering certain
mouse events (left-mouse clicking in particular) on my MS Intellimouse
(in fact, it was working before I started typing the email, and now it
stopped again... might be because of the middle mouse button on my
wheel because that's the only thing I really did). Some of the issues
appear to be tied to the keyboard too (using the Alt-Tab key
combination doesn't always switch windows), so maybe it's a deadlock
of some kind in Xorg? I say this because issuing some commands to
xinit on a console (^T -> SIGINFO) screws up Xorg when I switch back
to VTY-9 (it fails to render the screen). I run into this frequently
with Firefox (maybe with its focus stealing?) compared to other apps,
and sometimes I can do some minor keyboard gymnastics in order to get
things back to a sane state.
    I don't run into these issues on the 9-STABLE machine I use at
work, but granted, there's a software/hardware delta. I need some help
figuring out how to diagnose the issue (apart from xev -- which isn't
providing me with a lot of info), as truss is useless and turning on
ktrace is like getting a fire hose worth of unhelpful info.
    I have a pretty bleeding edge ports tree with minor modifications
(but not in any areas that should be causing this).
    In order to diagnose the problem, I've tried the following steps:
    1. Restart moused (no change).
    2. Unplugging and replugging devices (no change).
    3. Built ports with clang and gcc (no change) [going back to
building ports with clang BTW].
    4. Tried multiple DEs/WMs (Fluxbox, LXDE, XFCE4). Run into the
same issue at various points in time on all 3 (it's particularly
painful with Fluxbox for some odd reason because I generally can
right-mouse click in fluxbox, but can't do much else apart from that).
    Other things I could try and building ukbd/ums as a module instead
of building it into the kernel to see if the device is getting into a
wonky state and reloading the device gets it back to a sane one.
    I've attached other hopefully helpful details at the bottom of the page.


FreeBSD fallout.local 10.0-CURRENT FreeBSD 10.0-CURRENT #2 r+96bb463:
Tue Jan  8 00:39:55 PST 2013
root at fallout.local:/usr/obj/usr/src/sys/FALLOUT  amd64

xorg.conf snippet:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/sysmouse"
        Option      "ZAxisMapping" "4 5 6 7"

Some relevant packages:

$ pkg info | egrep 'nvidia|xorg'
linux-f10-xorg-libs-7.4_1      Xorg libraries (Linux Fedora 10)
nvidia-driver-304.64           NVidia graphics card binary drivers for
hardware OpenGL rendering
nvidia-settings-310.14         Display Control Panel for X NVidia driver
xorg-7.5.2                     X.Org complete distribution metaport
xorg-apps-7.5.2       apps meta-port
xorg-cf-files-1.0.4   cf files for use with imake builds
xorg-docs-1.6,1       documentation files
xorg-drivers-7.5.2    drivers meta-port
xorg-fonts-7.5.1      fonts meta-port
xorg-fonts-100dpi-7.5.1        X.Org 100dpi bitmap fonts
xorg-fonts-75dpi-7.5.1         X.Org 75dpi bitmap fonts
xorg-fonts-cyrillic-7.5.1      X.Org Cyrillic bitmap fonts
xorg-fonts-miscbitmaps-7.5.1   X.Org miscellaneous bitmap fonts
xorg-fonts-truetype-7.5.1      X.Org TrueType fonts
xorg-fonts-type1-7.5.1         X.Org Type1 fonts
xorg-libraries-7.5.1  libraries meta-port
xorg-macros-1.16.1             X.Org development aclocal macros
xorg-server-1.7.7_6,1          X.Org X server and related programs

Xorg.0.log snippet:

(**) Option "Protocol" "auto"
(**) Option "Device" "/dev/sysmouse"
(**) Mouse0: Protocol: "auto"
(**) Option "CorePointer"
(**) Mouse0: always reports core events
(**) Option "Device" "/dev/sysmouse"
(==) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5 6 7"
(**) Mouse0: ZAxisMapping: buttons 4, 5, 6 and 7
(**) Mouse0: Buttons: 11
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(**) Mouse0: (accel) keeping acceleration scheme 1
(**) Mouse0: (accel) acceleration profile 0
(II) Mouse0: SetupAuto: hw.iftype is 4, hw.model is 0
(II) Mouse0: SetupAuto: protocol is SysMouse


ugen0.1: <UHCI root HUB Intel> at usbus0, cfg=0 md=HOST spd=FULL
(12Mbps) pwr=SAVE
ugen1.1: <UHCI root HUB Intel> at usbus1, cfg=0 md=HOST spd=FULL
(12Mbps) pwr=SAVE
ugen2.1: <UHCI root HUB Intel> at usbus2, cfg=0 md=HOST spd=FULL
(12Mbps) pwr=SAVE
ugen3.1: <EHCI root HUB Intel> at usbus3, cfg=0 md=HOST spd=HIGH
(480Mbps) pwr=SAVE
ugen4.1: <UHCI root HUB Intel> at usbus4, cfg=0 md=HOST spd=FULL
(12Mbps) pwr=SAVE
ugen5.1: <UHCI root HUB Intel> at usbus5, cfg=0 md=HOST spd=FULL
(12Mbps) pwr=SAVE
ugen6.1: <UHCI root HUB Intel> at usbus6, cfg=0 md=HOST spd=FULL
(12Mbps) pwr=SAVE
ugen7.1: <EHCI root HUB Intel> at usbus7, cfg=0 md=HOST spd=HIGH
(480Mbps) pwr=SAVE
ugen5.2: <Microsoft Optical Mouse with Tilt Wheel Microsoft> at
usbus5, cfg=0 md=HOST spd=LOW (1.5Mbps) pwr=ON
ugen4.2: <Comfort Curve Keyboard 2000 Microsoft> at usbus4, cfg=0
md=HOST spd=LOW (1.5Mbps) pwr=ON

My KERNCONF can be found here:

More information about the freebsd-x11 mailing list