configure: error: /usr/bin/cpp does not preserve whitespace

Niclas Zeising zeising at
Sun Dec 9 21:31:36 UTC 2012

On 12/09/12 17:49, Chris Rees wrote:
> On 9 December 2012 16:20, Niclas Zeising <zeising at> wrote:
>> On 12/09/12 05:36, AN wrote:
>>> Correct, I noted that here:
>>> Description
>>> Trying to install SSVNC, it is failing to build imake.
>> The issues with clang and imake are known, however, no fix currently
>> exists.  If you have time on your hands, you could try to get imake
>> working with ucpp.  I don't know if this will work, but currently I
>> can't test myself.
> From my very brief look... r286772 by dinoex appears to work fine
> anyway-- can't we just use ucpp unconditionally?  It takes seconds to
> build, and doesn't mess about worrying about whether clang is default
> or not (it checks wrongly btw).
> Unless I've missed something obvious, could we take this for an
> exp-run perhaps?  It builds just fine for me on my -HEAD system;
> [crees at hydra]~% cc --version
> FreeBSD clang version 3.2 (trunk 162107) 20120817
> Target: x86_64-unknown-freebsd10.0
> Thread model: posix
> [crees at hydra]~%
> Chris

This might make imake build using clang and ucpp, but have you tried any
ports that utilize imake?  My experience is that having ucpp as CPP (or
RAWCPP) makes the configure script happy, but that it is still not
compatible enough with gnu cpp to make things (libX11, xorg-server) happy.
Niclas Zeising

More information about the freebsd-x11 mailing list