Problem with port libX11-1.2.1

John Hein jhein at
Sun Sep 20 21:02:46 UTC 2009

Timothy Myers wrote at 12:47 -0500 on Sep 20, 2009:
 > Dear maintainer,
 >                 Here is the config.log (attached), the output from the
 > failed make command (1st) and the output of ls /var/db/pkg (2nd).
 >                 While this specific error occurred while trying to make K3B,
 > this same error also occurred while I was trying to make Yakuake.
 > ===>  Configuring for
 > libX11-1.2.1_1,1
 > checking for a BSD-compatible install... /usr/bin/install -c -o root -g
 > wheel
 > checking whether build environment is sane...
 > yes
 > checking for a thread-safe mkdir -p... ./install-sh -c
 > -d
 > checking for gawk...
 > gawk
 > checking whether make sets $(MAKE)...
 > yes
 > checking whether to enable maintainer-specific portions of Makefiles...
 > no
 > checking if xorg-macros used to generate configure is at least 1.2... yes,
 > 1.2.1
 > checking whether we are using the GNU C compiler... (cached) yes
 > checking whether cc accepts -g... (cached) yes
 > checking for cc option to accept ISO C89... (cached) none needed
 > checking dependency style of cc... (cached) gcc3
 > CWARNFLAGS+= -Wold-style-definition -Wdeclaration-after-statement: not found
 > checking for cpp... /usr/bin/cpp
 > checking if /usr/bin/cpp requires -undef... yes
 > checking if /usr/bin/cpp requires -traditional... yes
 > checking whether to use XCB... (cached) yes
 > ./configure: 12276: Syntax error: word unexpected (expecting ")")

This complaint pops up on the list once every week or two.

It's not an x11 problem, but some problem with autoconf

In your case, it may be compounded by running in a PC-BSD environment.
Maybe other PC-BSD lurkers on the list can comment.

At one point there was a couple days when a bash update (on
2009-03-12) was causing autoconf configure script failures, but that
was just a one-day hole.

I've tried to reproduce it locally with various combinations
of autoconf, automake, etc., and maybe others have as well.

But I've never seen any post that explains the 

The most likely candidate I believe is some old .m4 autoconf file
(normally installed in /usr/local/share/aclocal, but pcbsd may have
some elsewhere, too) that perhaps has nothing (directly) to do with
the libX11 port or from an older out-of-date port that libX11 is using
as a dependency.

In any case, it sure would be nice if someone could figure
out what causes this problem for people.  Perhaps that means
debugging the generated configure script.  Maybe it means
doing a search to find an out of date .m4 file or port.

If you're not up to figuring that out, post your configure script
(generated by autoconf/make) and maybe someone else can take a look at

More information about the freebsd-x11 mailing list