xorg+i810+widescreen problems

Kim Højgaard-Hansen kimrhh at gmail.com
Fri Oct 26 03:06:20 PDT 2007


I hope this is the right place to ask, tried on IRC without luck.

I have an IBMX41 with Intel graphics i915, and an external widescreen TFT. I
have been strugling to make it work with the current xorg in ports, and
FreeBSD-6.2. It have had working on FreeBSD-7.0, but decided to switch to
stable since I don't have the time for -current :)

so, following the handbook I have used i915resolution to patch in the right


915resolution starts with the pc, verified by output

and setting up the modeline in xorg.conf found in /var/log/Xorg.0.log


Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "HWP"
        ModelName    "hpw2207"
#(II) I810(0): Supported additional Video Mode:
#(II) I810(0): clock: 146.2 MHz   Image Size:  473 x 296 mm
#(II) I810(0): h_active: 1680  h_sync: 1784  h_sync_end 1960 h_blank_end
2240 h_border: 0
#(II) I810(0): v_active: 1050  v_sync: 1053  v_sync_end 1059 v_blanking:
1089 v_border: 0
        ModeLine        "1680x1050" 146.2 1680 1784 1960 2240 1050 1053 1059
#       HorizSync       24-82
#       VertRefresh     48-76
        Option          "DPMS"

note: I also tried with the sync rates commented in, doesn't help

Section "Device"
        Identifier  "Card0"
        Driver      "i810"
        VendorName  "Intel Corporation"
        BoardName   "Mobile 915GM/GMS/910GML Express Graphics Controller"
        BusID       "PCI:0:2:0"

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes   "1680x1050" "1280x1024" "1024x768"


I have also put the agp module i loader.conf, but I think it is already
compiled into the GENERIC kernel?

dmesg | grep 'agp'
agp0: <Intel 82915GM (915GM GMCH) SVGA controller> port 0x1800-0x1807 mem
0xa0080000-0xa00fffff,0xc0000000-0xcfffffff,0xa0000000-0xa003ffff irq 16 at
device 2.0 on pci0
agp0: detected 7932k stolen memory
agp0: aperture size is 256M
drmsub0: <Intel i915GM>: (child of agp_i810.c) on agp0

So, how can I debug this problem further?

best regards

Kim Højgaard-Hansen

More information about the freebsd-x11 mailing list