only one button works on USB optical trackball.

John Ejaife jejaifejr at
Wed Oct 10 21:44:25 PDT 2007

When I enter X Windows, I can only one button does anything which is
the TWM 'iconify'-'exit' menu option, when I click the left trackball
button. I have to ctrl-alt-backspace to close out of Xwindows.

In dmesg, the mouse comes up as

ums0: Microsoft Microsoft Trackball Optical\M-., rev 1.10/1.21, addr
2, iclass 3/1
ums0: 5 buttons and Z dir.

In Xconfig, my mouse settings are

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Auto" # Auto detect
Option "Device" "/dev/ums0"

I've tried adding the
Option "Buttons" "7"
Option "ZaxisMapping" "4 5"

but neither of these have worked.

In rc.conf, I have

I have also tried the with and with out the xmodmap command
xmodmap -e "pointer 1 2 3 6 7 4 5 8 9 10 11"
which I've either placed in .xsession, or typed in an xterminal
window, but for the life of me, I can only seem to get one mouse
button to work.

More information about the freebsd-x11 mailing list