Upgrading to Xorg 7.2.0

Christopher Prance christopher.prance at gmail.com
Thu May 24 10:15:14 UTC 2007

Hello all,

I've been having some problems while trying to upgrade to Xorg 7.2.0, it
seems that when I'm doing a pkgdb -F and I run into stale dependency for
anything -> xdriinfo, it fails with this as it builds:

===>   xdriinfo-1.0.1_1 depends on file:
/usr/local/libdata/pkgconfig/glproto.pc - found
===>   xdriinfo-1.0.1_1 depends on file: /usr/local/libdata/pkgconfig/x11.pc
- found
===>   xdriinfo-1.0.1_1 depends on executable in : pkg-config - found
===>   xdriinfo-1.0.1_1 depends on shared library: glut.4 - found
===>  Configuring for xdriinfo-1.0.1_1
configure: WARNING: you should use --build, --host, --target
checking for a BSD-compatible install... /usr/bin/install -c -o root -g
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for i386-portbld-freebsd6.2-gcc... cc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of cc... gcc3
checking for a BSD-compatible install... /usr/bin/install -c -o root -g
checking return type of signal handlers... void
checking for i386-portbld-freebsd6.2-pkg-config... no
checking for pkg-config... /usr/local/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for XDRIINFO... yes
checking for library containing glXGetProcAddressARB... no
configure: error: cannot find GL library - make sure Mesa or other OpenGL
package is installed
See `config.log' for more details.
===>  Script "configure" failed unexpectedly.
Please report the problem to x11 at FreeBSD.org [maintainer] and attach the
"/usr/ports/x11/xdriinfo/work/xdriinfo-1.0.1/config.log" including the
of the failure of your make command. Also, it might be a good idea to
an overview of all packages installed on your system (e.g. an `ls
*** Error code 1

Stop in /usr/ports/x11/xdriinfo.

I have actually just deleted the dependency which I hope did not mess
anything up.  I'm still learning as I go so any help would be appreciated.
All of my LibGL, libGLU, and libglut, are installed and still no luck. 

Christopher Prance

More information about the freebsd-x11 mailing list