HEADS UP: xorg upgrade plans

Coleman Kane cokane at cokane.org
Wed May 2 22:21:29 UTC 2007

On Wed, 2007-05-02 at 15:43 -0400, Kris Kennaway wrote:
> On Wed, May 02, 2007 at 02:40:26PM -0500, Stephen Montgomery-Smith wrote:
> > 
> > 
> > On Wed, 2 May 2007, Kris Kennaway wrote:
> > 
> > >Hi all,
> > >
> > >After many months of hard work (mostly by flz@, as well as others) we
> > >are approaching readiness of the xorg 7.2 upgrade.  Because this is a
> > >huge and disruptive change, we're going to approach it very carefully.
> > 
> > I tried X 7.2 about a week ago, and I can report some minor problems.
> > 

I've been following the xorg 7.2 tree for some time, and recently around
the time of either the move to /usr/local or the ruby18 update (they
happened pretty close together for me) portupgrade -na seems to have
broken for me. It just hangs there forever, seemingly doing something in
the background and never actually starts checking for updated ports.
Tried rebuilding INDEX, INDEX.db, and pkgdb.db to no avail... Once I let
it go overnight and the process died with an Illegal Instruction

> > First, "pkg_delete -a" took far too long.  X7.2 has so many dependencies, 
> > that I sense that it is beginning to overload the ports structure.  My 
> > guess is that "pkg_delete -a" spends a huge amount of time just checking 
> > out all the dependencies before it even starts.
> To some extent this is true.  It's not something we can fix now though.
> > Secondly, X7.2 as I tried it wouldn't "startx" if some other login had 
> > created a .Xauthority file.  While "rm .Xauthority" solved the problem 
> > completely, I don't think this is user friendly.
> I think I ran into this once a while back, I don't know what is the
> correct solution.
> Kris

Coleman Kane

More information about the freebsd-x11 mailing list