Centos7 uefi boot problem with bhyve after update

Michael Reifenberger mike at reifenberger.com
Fri May 4 12:26:44 UTC 2018

Zitat von Jason Tubnor <jason at tubnor.net>:

> On 2 May 2018 at 19:58, Michael Reifenberger <mike at reifenberger.com> wrote:
>> Hi,
>> Im running a Centos7 bhyve VM under FreeBSD-11 (latest stable).
>> The VM boots using UEFI: uefi-edk2-bhyve-0.1
>> Centos was installed and ist booting fine: CentOS Linux release 7.3.1611
>> (Core)
> What Kernel version are you running here?  Have you tried
> uefi-edk2-bhyve-20180318 ?
Centos (the older working one):
Linux nw3 3.10.0-514.26.2.el7.x86_64 #1 SMP Tue Jul 4 15:04:05 UTC  
2017 x86_64 x86_64 x86_64 GNU/Linux
It was installed Sep.2016 using CentOS-7-x86_64-LiveKDE.iso

The newer one (the non working), I dont know currently, but should be  
a 3.10.* kernel as well.

uefi-edk2-bhyve-20180318 ist the latest one?
Yes. I used this version to get the Screenshot.

>> BTW:
>> A new installation of a recent Centos fails after the installation/reboot
>> with the same error.
>> Other Linux distros (Ubuntu) seem to be affectet too...
> Can you define the version of Ubuntu that you are testing with and the
> kernel that it is running?  Ubuntu 17.10 Server stock works fine with the
> currently supplied UEFI shims, but there are known issues with 18.04 with
> fixes in the pipeline.
> Cheers,
> Jason.

I used:
and, I think,

Kernelversion I don't know.

The kernel version shouldn't matter that much because the error  
occures before the kernel gets loaded.
It's after /EFI/BOOT/BOOTX64.EFI got loaded and before  
/EFI/centos/grubx64.efi gets loaded
because of not beeing found...


Michael Reifenberger

More information about the freebsd-virtualization mailing list