Segmentation fault in grub-bhyve when trying to boot a Linux guest

Mark Raynsford list+org.freebsd.virtualization at
Wed May 2 08:51:23 UTC 2018

On 2018-05-01T18:06:38 -0700
Peter Grehan <grehan at> wrote:

> >    * rosemary_disk0.lzma (the LZMA compressed zvol)  
>   I was able to boot this image on a 12-current Ryzen system. Debian 9.4 
> also installed fine with the netinstall ISO and could boot.

Bizarrely, I am also able to boot it without issue now. I worked
through this with someone in the #bhyve channel on Freenode.

I couldn't boot the image with the stripped grub-bhyve binary, this
would crash reliably. Restarting the hardware didn't make any
difference, and destroying the vm after each attempt didn't make any
difference either.

I couldn't boot the image with the debug grub-bhyve binary. The same
applied to that as above.

If I ran the debug binary in gdb 8, the program ran to completion
without crashing. After running it a few times without crashing in gdb,
both the stripped and debug grub-bhyve binaries would run to completion
*outside of the debugger* without crashing!

Both the stripped and debug grub-bhyve binaries reliably work now. I
can boot the VM, reboot it, whatever. I've restarted the hardware many
times and cannot reproduce the original crash.

I've never seen anything like this and have no theories as to why it
didn't work at all, and now works reliably despite nothing apparently
having changed anywhere.

Mark Raynsford |

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 228 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the freebsd-virtualization mailing list