Resizing ZVOL used for bhyve VM.

Dean E. Weimer dweimer at
Wed Feb 8 05:39:40 UTC 2017

I am trying to resize a secondary data disk on a Debian Linux Virtual 
machine. The data really isn't all that important, its video from IP 
security cameras. Since nothing has happened that needs reviewed I could 
scrap it and start over. However I can't even do that.

I tried just setting the volsize to a larger value while the vm is 
shutdown. zfs excepts the command, I boot up the VM but it is not 
recognizing the volume properly I can see that its grown, but it errors 
trying to update the GPT partition table with the new size. I gave up 
shutdown VM and tried to delete the zvol so I could create a new one. 
However it believes the zvol is in use and wont let me destroy it. So 
something funky seems to be going on. oddly enough I set the zvol back 
to the original size boot up the vm, all the data is intact and 
functioning just fine. So somehow I can't break it despite doing all 
kinds of things that could have and probably should have destroyed the 

I am going to guess the only thing I have left to try is disable vms on 
startup and reboot to see if I can then destroy the zvol and create a 
new larger one. But I was hoping someone else might have another 
suggestion to correctly increase the volume size.

    Dean E. Weimer

More information about the freebsd-virtualization mailing list