bhyve on AMD, linux and high load

Willem Jan Withagen wjw at
Thu May 22 23:03:09 UTC 2014

On 22-5-2014 21:29, Nils Beyer wrote:
> Hi,
> Willem Jan Withagen wrote:
>> I've just completed merging and patching with Anish patches...
>> ONce that seems to run for my freebsd vm's, I'll start merging my
>> patches. And hope that it still works.
> Sounds good. I've tried some Linux versions ranging from 2.6.32, 3.10.x,
> 3.11.10 to 3.12.8 using an Anish's patched SVM+HEAD variant. They all
> show the same behaviour being stucked during boot.
> I haven't tried your patches yet, though.

Well I'm running Anish SVM+HEAD and I'm no longer able to my old FreeBSD
vm's. And I can't even get to build new ones....

It just doesn't show anything on the commandline output, even if I go:
	-l com1,stdio

Strange part is that the Linux 14.04 VM just starts fine....

So I have a complete reverse situation.
Linux runs, but I have a hard time getting FreeBSD to run.

>> And best would be that the vlapic stuff gives a extra bit of speed,
>> because we're not quite there yet.
> I suppose you start your bhyved Linux instances using the "-A" switch (ACPI
> tables), right? If you feel interested, you can try to start them without the
> "-A" switch. For me, the boot process is now stucked at "Calibrating delay
> loop". As far as I understand, it probably has something to do with a borked
> "jiffies" value and that has probably something to do with a borked "IRQ 0"
> that modifes that "jiffies" value at every tick.

Yes I use -A on all my boots.

> But these are just wild guesses as I understand much too little about
> kernels, virtualizing and stuff.

I'm the last one suggesting that I know more that just a little bit, but
I get by..

> For what it's worth, using an Intel i3 and without the "-A" switch, the
> bhyved Linux instance just boots fine as it does with the "-A" switch.

One of the reasons tinkering with AMD is that I don't have an i{3,5,7}
cpus available.

> BTW: you haven't the oppurtunity to try bhyve SVN on a Barcelona- or later
> class Opteron, have you?

Nope, just got a bunch of boards leftover from a previous project. And
they are all:
CPU: AMD Phenom(tm) II X6 1075T Processor (3013.83-MHz K8-class CPU)
  Origin="AuthenticAMD"  Id=0x100fa0  Family=0x10  Model=0xa  Stepping=0

More information about the freebsd-virtualization mailing list