bhyve: svm (amd-v) update

Willem Jan Withagen wjw at
Wed May 21 07:11:27 UTC 2014

On 2014-05-21 6:59, Anish wrote:
> Hi Willem,
> Thanks for sharing your patch. I see that you have gone further than
> what I have. Are you able to boot Linux with these changes?

I'm running ubuntu-{12.x,14.04} with this and I'm able to compile the 
linux kernel. Peter helped a lot in getting it going.

Although that is already takeing something like a week... So it is slow.
You might also need my ahci hack/patch, since linux uses a lot of 
flushes and there is a 'bug' in the FreeBSD end of ahci that does not 
really cooperate with the way ubuntu-14.04 calls it.
So I've emulated a flush to a NO-OP. which then results in a panic 
because the ahci command-list is empty. So I 'fixed' that too, and then 
things run, albeit slow.

CentOS it tried at the begining, but I'm just not a RH fan, so when that 
was too slow, I gave up.

Give some time and I'll try and extract my ahci-hack-patch, and that is 
the last part that'll let you get on your way, booting linux.

I do not have a lot of time to look at this, so I'm already a few weeks 
stuck on speeding up the linux-kernels.
Also because I do not know enough of the inards of Linux..


> Thanks and regards,
> Anish
> On Tue, May 20, 2014 at 2:03 PM, Willem Jan Withagen <wjw at
> <mailto:wjw at>> wrote:
>     On 15-5-2014 17:56, Anish wrote:
>      > Hi Andriy,
>      >  Thanks for your interest in SVM port of bhyve. I do have patch
>     to sync it
>      > to
> If
>      > patches looks good to you, we can submit it. I have been testing
>     it on
>      > Phenom box which lacks some of newer SVM features.
>     I don't quite understand against what this patch is?
>     Do I run it over head, to get SVM code into head?
>     Or do I patch against bhyve_SVM, because in the later case I get
>     complaints that
>               fatal error: 'vlapic_priv.h' file not found
>     # locate vlapic_priv.h
>     /usr/srcs/head/sys/amd64/vmm/io/vlapic_priv.h
>     So I'm guessing that is against head.
>     But last time I looked at head, more than just the interrupt stuff was
>     missing....
>     --WjW

More information about the freebsd-virtualization mailing list