FreeBSD PVHVM call for testing

Jeroen van der Ham jeroen at
Mon Jul 22 07:20:58 UTC 2013


After some more testing I thought it would be good to put this into production for my personal server. I've used pvhvm_v19 and built it without debugging options and installed it on a FreeBSD 9.1 system.

I've run into some hiccups with 9.1 user land and a 10-CURRENT kernel, but that's all solvable[0].

My VPS has some very limited memory (256M), but I've compensated with swap space (1G)

Now anytime I'm putting the system under stress, by building ports or by running a git clone on the kernel repository here, I'm seeing a lot of messages about swap_pager:

> swap_pager: indefinite wait buffer: bufobj: 0, blkno: 132545, size: 4096

The system also becomes very sluggish and sometimes unresponsive.
The weird thing was that one of these messages happened right after a reboot when I rebuilt an outdated port and on the main console was checking the swap memory:

> jeroen:~/ $ swapinfo                                                  [8:13:29]
> Device          1K-blocks     Used    Avail Capacity
> /dev/ada0p2        524288     2484   521804     0%
> /dev/md0          1048576     2364  1046212     0%
> Total             1572864     4848  1568016     0%
> swap_pager: indefinite wait buffer: bufobj: 0, blkno: 131424, size: 4096

Is anyone else seeing something similar?
I certainly did not experience something like this on 9.0 with a XENHVM kernel.

If necessary I can rebuild a kernel with debugging support and do some more recording of what is actually going on.


[0]: I have edited to always apply the FBSD10_FIX, and for version checking I am  running "pkg version" with UNAME_r=9.1-RELEASE.

More information about the freebsd-virtualization mailing list