FreeBSD 8.2 (i386) does not install under Hyper-V

Scheller, Roland scheller.r at
Tue Apr 12 11:47:58 UTC 2011


I'm facing issues with installing and updating of FreeBSD 8.2 (i386) under Hyper-V (Windows Server 2008, Service Pack 2):

1. Update Freebsd 8.0 (i386) -> 8.2 under Hyper-V (via cvsup)

FreeBSD 8.0 is running fine under Hyper-V on this system since a long time. I had no issues at the time when I installed it. Now I tried to update it to a more recent version:

No issues with "make buildworld", "make buildkernel", but after "make installkernel" the VM does not boot any longer. Instead the following error message is displayed: "freebsd unsopported version Elf_Verdef".

2. Then I tried to install FreeBSD 8.2 into a new VM (via ISO image)

I received several error messages during the installation, several packages can't be installed: "Add of Package xx aborted, error code 0".

Debug Screen:

ldconfig: warning: /usr/local/Lib: No such file or directory

pkg_add: could' t remove temporary dir '/var/tmp/instmp.y3gyg8'

pkg_add: leave_playpen: can' chdir back to ''

pid 72 (sh), uid 0: exited on signal 11 (core dumped) pid 73 (sh), uid 0: exited on signal 11 (core dumped) ...

(several similiar lines with "core dumped" follow.)

Eventually the installation abends with: "Could'nt extract the following distributions. This may be because they were not available on the installation media you've chosen:" (A lot of packages are



"Cannot dump. Device not defined or unavailable. Automatic reboot in 15 seconds - press a key on the console to abort"

After the restart the bootloader displays several error messages with dump info and then stops with "BTX halted".

I did validate the MD5 sum of the image.

Another attempt to use VHD as SCSI disk failed as well -> the drive is not recognized (No Disks Found!)

Then I tested the installation of FreeBSD 8.2 (same image) on my desktop under Virtualbox (Windows 7) successfully. This did work without issues. Unfortunately this does not help with my Windows Server 2008.

Is this a known issue?



More information about the freebsd-virtualization mailing list