Is FreeBSD-current XHCI 1.1 compliant?

Rajesh Kumar rajfbsd at
Thu Aug 30 13:56:10 UTC 2018

Thanks Hans.

We tried to gather some storage performance benchmarking numbers. But we
are seeing poor benchmark number with USB 3.1 gen1/gen2  when compared with
SATA (For test, we connected a SATA SSD using direct SATA cable (or)
through a USB-SATA bridge).  So, just enabled streams mode
(hw.usb.xhci.streams=1) with no luck (expected, as you say no drivers are
currently using it). After a quick debug, seems
UE_GET_BULK_STREAMS(ecomp->bmAttributes) returns 0. So, Default mode (may
be BULK) is chosen instead of streams mode.

So, does using streams mode helps in improving the storage performance with
USB? If so, what is needed to use streams mode effectively?  Do we need to
consider anything else when taking USB performance numbers in FreeBSD?

On Wed, Aug 29, 2018 at 12:35 AM Hans Petter Selasky <hps at>

> On 8/28/18 6:41 PM, Rajesh Kumar wrote:
> > Hi Hans,
> >
> > We have tried using a SSD disk with a USB 3.1 gen 2 to SATA bridge device
> > (XHCI 1.1).  The disk is detected and usable.  But seems it works in
> > "Bulk-Only" mode. Is there any plans to support USB attached SCSI?  I
> see a
> > tunable "hw.usb.xhci.streams" to enable USB streams.  But seems it does
> > nothing much.
> Hi,
> Streams mode is disabled by default (hw.usb.xhci.streams=0) and we have
> no drivers using it :-(
> --HPS

More information about the freebsd-usb mailing list