FreeBSD 8.2 and DisplayLink devices?

Torfinn Ingolfsen torfinn.ingolfsen at broadpark.no
Sun Jul 10 17:44:12 UTC 2011


Hi,

Has anybody done any work on DisplayLink devices for FreeBSD?
I have a small monior, Lilliput UM-70[1], which uses DisplayLink.
The last time I tested it was when FreeBSD 7.2 was hot. :)

Today I blew the dust off the monitor and connected it to a test machine:
root at kg-v7# uname -a
FreeBSD kg-v7.kg4.no 8.2-STABLE FreeBSD 8.2-STABLE #7: Sat Jul  9 23:00:31 CEST 2011     root at kg-v7.kg4.no:/usr/obj/usr/src/sys/GENERIC  amd64

It shows up fine:
root at kg-v7# usbconfig -d 0.3
ugen0.3: <LILLIPUT USB Monitor DisplayLink> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON
from /var/log/messages:
Jul 10 18:57:44 kg-v7 root: Unknown USB device: vendor 0x17e9 product 0x02a9 bus uhub2
Jul 10 18:57:44 kg-v7 kernel: ugen0.3: <DisplayLink> at usbus0

But I don't have anything to actually use it. I downloaded libdlo-0.1.2.tar.gz (found at thw libdlo wiki[2])
and tried to get it working:
./configure
./configure --includedir=/usr/local/include
./configure --includedir=/usr/local/include --libdir=/usr/local/lib
./configure --includedir=/usr/include --libdir=/usr/lib

all results in "configure: error: Can't find libusb. On ubuntu, try sudo apt-get install libusb-dev".

Any hints on getting this working?

References:
1) http://sites.google.com/site/tingox/lilliput_um70
2) http://libdlo.freedesktop.org/wiki/
-- 
Torfinn



More information about the freebsd-usb mailing list