impossible to work with the scanner

Andrew Muhametshin andrew at
Sun Jul 8 08:29:21 UTC 2007


It is absolutely impossible to work with the scanner! After scanning 
there are extraneous strips. An example here (310Kb):
...Or, process of scanning hangs.

For check, I tried to use same the scanner on other systems (Linux, and 
Windows) -- And in them, all worked perfectly. This problem, is inherent 
only in FreeBSD.

$ uname -a
FreeBSD host01 6.2-STABLE FreeBSD 6.2-STABLE #0: Fri Jul  6 20:39:20 MSD 
2007     root at inspirra.localdomain:/SHARED/obj.host01/usr/src/sys/HOST01 

And new USB stack, revision 531

$ scanimage -L
device `epson:/dev/uscanner0' is a Epson GT-9300 flatbed scanner

$ egrep "^usb4|uscanner" /var/run/dmesg.boot
usb4: EHCI version 0.95
usb4: <VIA VT6202 USB 2.0 controller> on ehci0
usb4: 480MBps High Speed USB v2.0
uscanner0: <EPSON EPSON Scanner, class 255/255, rev 2.00/1.00, addr 126>

With the best regards,
Andrew M.

I am sorry for my English. I am compelled to use the electronic translator

More information about the freebsd-usb mailing list