[Bug 220767] lang/beignet: hangs if consumer is not linked against libpthread after jemalloc 5.0.0 update

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Tue Jan 23 09:55:51 UTC 2018


--- Comment #5 from Alexey Dokuchaev <danfe at FreeBSD.org> ---
(In reply to Jan Beich from comment #4)

FWIW, I've tried to play with malloc_mutex_first_thread() implementation,
JEMALLOC_MUTEX_INIT_CB (+ some related macros), using different atomics
implementation in jemalloc 5.0.0, all without any luck.

For the record, I'm including this advice from John Baldwin:
> I wonder if it is tripping over pthread_once not working in libc.  The stub
> for pthread_once in libc is a nop and has been for a long time.  I added
> a functioning stub (called _libc_once) to libc for it's internal use (there
> is a _once() wrapper that will call _pthread_once when using libpthread and
> _libc_once otherwise).  It might be interesting to build jemalloc with
> '-Dpthread_once=_once' to see if that makes a difference?
I've tried this as well and it did not help.

You are receiving this mail because:
You are on the CC list for the bug.

More information about the freebsd-threads mailing list