KSE does not appear to work when I run FreeBSD 6.2 on VMware

Akshay Kawale freebsd_noob at yahoo.com
Sat Oct 6 19:09:53 PDT 2007


I'm writing a small thread library based on KSE.
I've got some initial code ready that performs an upcall when I create a new KSE.

However, this code only works on a physical machine. When I run FreeBSD on VMware, my program does not appear to perform the upcall. I know that it's not upcalling because I intentionally seg fault in my upcall function. (I also put a gdb breakpoint at the upcall function, which does not hit).

I've tried this on a stock 6.2 RELEASE Kernel (Physical Machine) and on 6.2 RELEASE and 6.2 RELEASE-p8 (VM).

My /proc does not appear to be set up, so I can't use 'truss' to figure out if the KSE Syscalls are actually being called.

truss: cannot open /proc/curproc/mem: No such file or directory
truss: cannot open1 /proc/1044/mem: No such file or directory

I wrote a small threaded program using pthreads, and that appears to work ok on VMware.

Does anyone have an idea what could be wrong?
Any suggestions to help me debug?


- Akshay

Shape Yahoo! in your own image.  Join our Network Research Panel today!   http://surveylink.yahoo.com/gmrs/yahoo_panel_invite.asp?a=7 

More information about the freebsd-threads mailing list