pthread malloc and abort() (Was: libthr question)

Paul Khavkine paul.khavkine at
Thu Feb 2 14:31:50 PST 2006

On Wed, 2006-02-01 at 14:10 -0500, Daniel Eischen wrote:
> On Wed, 1 Feb 2006, Paul Khavkine wrote:
> >
> > Hi Daniel.
> >
> >
> > I tried running the application with Electric Fence and this is what i
> > get:
> >
> > ElectricFence Exiting: mmap() failed: Cannot allocate memory
> I've no clue.  ulimits?


I had no luck setting up ElectricFence.

Now my question is, the application dies with either free() or realloc()
errors and sig Abort.

However it does not produce a core dump, even when i run it in gdb, gdb
either dies itself with sig abort or says something like "abort, process
went away". Is this normal, it seems that it SHOULD produce a core file.

Btw, the program is compiled with libpthread.

OS version is: 5.4-RELEASE-p6 SMP
Hardware is: DL360 G4 dual Xeon 3Ghz, 2G memory, 2x36G U320 drives in
RAID1 config.

This does not happend when running a UP kernel, only SMP.

Any pointers on why this is happening ?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 305 bytes
Desc: This is a digitally signed message part
Url :

More information about the freebsd-threads mailing list