[RFC] Rename `make test` in suite.test.mk with `make regress`
yaneurabeya at gmail.com
Sat Oct 17 22:03:47 UTC 2015
There’s a lesser known target in suite.test.mk that runs `kyua test` in a similar manner to how Jenkins and other groups have integrated kyua into their test infrastructures.
The legacy target on FreeBSD was `regress`, but the target created with the bsd.test.mk creation back a few years ago was `test`. Why change from `test` to `regress`? There are places in the tree (bin/test for example) that have targets named test, so in order to avoid clashing with a common target (name), it’s best to use the legacy target name.
Would anyone have any serious heartburn over the change?
More information about the freebsd-testing