Using drm-next in 11.2

Pete Wright pete at
Tue Sep 11 17:59:32 UTC 2018

On 9/11/18 7:44 AM, Pete French wrote:
> On 11/09/2018 14:42, Pete French wrote:
>>> I think you have to use kld_list="/boot/modules/amdgpu.ko" to get 
>>> the new one.
>> Will give it a try - I think its unnecessary as the name doesnt 
>> clash, but worth a go...
>> -pete. [quick reboot comming up]
> I tired this, it doesnt help - I tink it alway was loading that one - 
> but I also tried a few other things. Such as removing my ATI driver 
> from Xorg and adding the amdgpu driver istead. Still no luck 
> unfortunately.

can you post your dmesg output from when you've set 
kld_list="/boot/modules/amdgpu.ko"?  also, please verify that your user 
is in the "video" group.  but from what you've described it sounds like 
a conflict is popping up between the base amdgpu.ko and the one 
available in the ports tree.

also, please ensure you are booting in "classic" BIOS mode and not UEFI, 
IIRC there are some issues surrounding amdgpu with UEFI - i don't have 
that hardware tho so can't elaborate.


Pete Wright
pete at

More information about the freebsd-stable mailing list