Can't boot on ZFS -- /boot/zfsloader not found

Steven Hartland killing at
Thu Jan 12 00:32:54 UTC 2017

On 11/01/2017 22:58, Jeremie Le Hen wrote:
> (Sorry I had to copy-paste this email from the archives to a new
> thread, because I'm not subscribed to -stable at . Would you mind cc:ing
> me next time please?)
>> As your not at the boot loader stage yet for keyboard enabling legacy
>> USB keyboard / mouse support in BIOS may help.
> That worked, thanks for the tip.
>> If you see issues with keyboard after the kernel takes over setting
>> hint.ehci.0.disabled=1 may help.
>> If your installing 11.x then the guides boot partition size is out of
>> date and you should use 512K for your freebsd-boot partition.
> Oh, really?  I'll update it once I'll have figure it all out.  That's
> weird though because /boot/gptzfsboot is less than 90 KB.
du -h /boot/gptzfsboot
  97K    /boot/gptzfsboot

du -h /boot/gptzfsboot
113K    /boot/gptzfsboot

The reason I'd recommend 512k for boot is to provide room for expansion 
moving forward, as repartitioning to upgrade is a scary / hard thing to 
do. Remember it wasn't long ago when it was well under 64k and that's 
what was recommend, its not like with disk sizes these days you'll miss 
the extra 384k ;-)
>> For the GPT version (I've never used MBR one) what actual error do you get?
> When I just start up the NUC, I get:
> """
> \Can't find /boot/zfsloader
> FreeBSD/x86 boot
> Default: zroot:/boot/kernel/kernel
> boot:
> \
> Can't find /boot/kernel/kernel
> """
> I though it was the first stage boot loader, but it may be the second stage.
Boot to a live cd, I'd recommend mfsbsd, and make sure the boot loader 
was written to ALL boot disks correctly e.g.
if you have a mirrored pool with ada0 and ada1:
gpart bootcode -b /boot/pmbr -p /boot/gptzfsboot -i 1 ada0
gpart bootcode -b /boot/pmbr -p /boot/gptzfsboot -i 1 ada0

If this doesn't help the output from gpart show, uname -a and zpool 
status would also be helpful.

This is all assuming standard BIOS mode and not UEFI which is done 

> -jlh
>> On 11/01/2017 19:22, Jeremie Le Hen wrote:
>>> Hi,
>>> I'm in the process of transferring my home server to an Intel NUC. I've zfs
>>> send/receive'd the whole pool to the new drive and first followed
>>> [ZfsOnGpt] but it fails in the first stage boot loader. The USB keyboard
>>> doesn't seem to be recognized so I can't really debug anything.
>>> Then I tried both [ZfsInMbrSlice]
>>> but it complains that it can't find /boot/zfsloader. Again USB keyboard
>>> doesn't work.
>>> Both times I've been very careful to install the bootcodes at the right
>>> place.
>>> 1. Any idea why the USB keyboard doesn't work?
>>> 2. Any idea what can be wrong in the setups I tried? How can I debug this?
>>> [ZfsOnGpt]
>>> [ZfsInMbrSlice]
>>> -jlh
>>> _______________________________________________
>>> freebsd-stable at mailing list
>>> To unsubscribe, send any mail to "freebsd-stable-unsubscribe at"

More information about the freebsd-stable mailing list