Possible kqueue related issue on STABLE/RC.

Jimmy Olgeni olgeni at olgeni.com
Thu Sep 12 07:45:52 UTC 2013

On Thu, 12 Sep 2013, Konstantin Belousov wrote:

>> This time I tried with clang + these options and I got something more
>> interesting. All works fine until the lock violation below:
> Clang is, well, not relevant there.

Still, with clang I could get a hard reset rather than a hang. But
maybe there are two different issues. I'll run more tests and see if
the fifo problem goes away with your patch below.

> It seems you edited the kernel output, at least rearranging large blocks
> of text.  I tried to interpret what I see in a useful way.

I got the message buffer from a minidump, here:


> Might be, your issue is that some filesystems do not care about proper
> locking mode for the fifos.  UFS carefully disables shared locking for
> VFIFO, but it seems ZFS is not.  I can propose the following band-aid,
> which could help you.

Thanks a lot! I'll give it a run when I get back home.


More information about the freebsd-stable mailing list