Problem with portsnap fetch

Efraín Déctor efraindector at
Fri Apr 5 18:50:17 UTC 2013

Hello. Today I ran into a problem when trying to update the ports tree.

I executed the following command:

# portsnap fetch

However I got this message:

Looking up mirrors... 6 mirrors found.
Fetching public key from done.
Fetching snapshot tag from done.
Fetching snapshot metadata... done.
Fetching snapshot generated at Fri Apr  5 00:09:09 UTC 2013:
2c954aa9458bb07dbefad840b7a06e3b9a5f5f90e10963100% of 1045  B 5101 kBps
Extracting snapshot... tar: Unrecognized archive format
tar: snap: Not found in archive
tar: Error exit delayed from previous errors.

Looking in the Internet I found that deleting the directory 
/var/db/portsnap/files should help, however it didn't work, also found 
that deleting the portsnap directory should do the trick, but this 
didn't work either I keep getting the same error message. The tar 
command is functioning correctly (I tested it).

uname -a:
FreeBSD 8.2-RELEASE-p3 FreeBSD 8.2-RELEASE-p3 #0: Tue Sep 
27 18:45:57 UTC 2011 
root at amd64

Can you guys please point me in the right direction?.

Thanks in advance.

More information about the freebsd-stable mailing list