cam SCSI negotiation issues (mpt in that case), only 3.300MB/s transfers

Harald Schmalzbauer h.schmalzbauer at
Fri Nov 23 13:43:37 UTC 2012


I have a LSI20320IE, wich is a LSI1030 (U320-SCSI, supported by MPT)
behind an PCI-X-PCIe bridge. I'm using that for two tape drives: LTO-3
and DAT72.
My (solved, see below) first problem was, that passthrough of that HBA
with ESXi5.0 didn't work.
As soon as mpt was kldloaded, there was a heavy interrupt storm detected
(>100k irq/s) and throttling occured. No matter what IRQ it was assigend
and no matter if it was shared or not. The dmesg output hasn't shown any
info about MSI usage, so I told ESXi to use legacy interrupts in host
mode instead of msi. Didn't help anything.

After I verified that this passthrough configuration works well on other
OS, I tried out some things and
found out that    hint.mpt.0.msi_enable="1"
solves the interrupt storm problem, although dmesg output still is
exactly the same:
    mpt0: <LSILogic 1030 Ultra4 Adapter> port 0x4000-0x40ff mem
0xd6440000-0xd645ffff,0xd6420000-0xd643ffff irq 18 at device 0.0 on pci3
    mpt0: MPI Version=
Btw, I'm still curious what the sysctl "hw.mpt.0.role" means? With my
LSI1030 it's "3", an onther 1068, it's "1"

Now after I got passthrough working, I first tried to saturate my LTO-3.
With the help of mbuffer (zfs send -R DATASET/filesystem at totape |
mbuffer -s 1m -t -m 500M -P 80 -f -o /dev/nsa1) I saw 60-120MB/s
transfer rates, avaeraging at 100MB/s at moderate interrupt load (~1k).
So for so fine.
But there are problems with the DAT72 drive.
The SCSI negotiation seems to fail:
sa0 at mpt0 bus 0 scbus3 target 0 lun 0
sa0: <SEAGATE DAT    DAT72-052 A16K> Removable Sequential Access SCSI-3
sa0: 3.300MB/s transfers

Now I read here
that this may be just cosmetic, but in my case I can't get more than
~3MB/s to/from the tape.
Once again I changed the controller to another guest OS and got 5,5MB/s
avarage write transfer rate with ntbakup (wich is sensible for the
gained compression ratio).
lsiutil.exe shows negotiation parameters with 80MB/s (40MT/s 16bit),
which correponds to the drive's interface.
Back in FreeBSD, I had no luck using "camcontrol negotiate sa0 -R 40" to
alter the negotiation parameters.
It always shows 3,300MB/s and seems to reflect reality.

I'd higly appreciate any help, since I have no idea how this could be
fixed. Slot-constraints  limit my choice of SCSI-HBAs to PCIe ones...



-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 196 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the freebsd-stable mailing list