problems with AHCI on FreeBSD 8.2

Harald Schmalzbauer h.schmalzbauer at
Tue Feb 14 19:24:36 UTC 2012

 schrieb Martin Sugioarto am 14.02.2012 19:23 (localtime):
> Am Tue, 14 Feb 2012 18:17:19 +0100
> schrieb Harald Schmalzbauer <h.schmalzbauer at>:
>>> I find it interesting that, at least so far, the only people
>>> reporting problems of this type with the ahci.ko driver are people
>>> using Samsung disks.  The only difference is that your models are
>>> F1s while the OPs are F2s.
>> I saw such timeouts long ago and mav@ had a look at my postings and he
>> mentioned it could be a NCQ problem.
>> I suspected the disks firmware.
>> I never tracked it down further, because after replacing the Samsung
>> (F3 in that case) disks with hitachi ones solved all my problems and
>> gave a big performance kick as well (with zfs).
>> You can find the discussion here:
> Hi,
> I just want to add here that I am using 2 drives of type "Samsung
> HD103SJ" (SpinPoint F3). And I did not have problems with ZFS and with
> UFS either (for several years now). Everything has been deployed ontop
> ada(4) since FreeBSD-8.
> Actually the speed is very good (sequential read at 140 MB/s and more).

I guess it's always the firmware of the EcoGreen models which cause
these problems. Your drive isn't EG...
I don't remember exactly the different model numbers, but I'm sure they
were all EcoGreen. The lower power consumption was the reason to choose
these specific drives (different capacities and F2/F3 series tried),
with acceptable performance loss - I thought. But it turned out that
EcoGreen and NCQ as well as RAIDZ demands dont' fit together...


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 196 bytes
Desc: OpenPGP digital signature
Url :

More information about the freebsd-stable mailing list