battery state

Dominic Fandrey kamikaze at
Thu Aug 16 08:24:55 UTC 2012

On 16/08/2012 07:39, Ian Smith wrote:
> On Wed, 15 Aug 2012 11:40:26 +0200, Dominic Fandrey wrote:
>  ...
> I found your correspondence here last December about that, "Re: battery
> display broken".  Looks like it's still the same problem, you were on
> 9-stable then too.  When did it used to work?

Hmm, I switched to RELENG_9 shortly before the 9.0 release. It had
worked then, or I'd have PRed a regression.

It stopped working around the beginning of this FSAE season. Probably
between September and December.

> On either normal or verbose boot messages, are there any ACPI errors
> logged?  This smells a bit like some of the Embedded Controller issues
> that were coming up late 2010, most resolved by some patches by avg at .

This is from the verbose dmesg:
# dmesg | grep -i bat
battery0: <ACPI Control Method Battery> on acpi0
battery1: <ACPI Control Method Battery> on acpi0
battery0: battery initialization start
battery1: battery initialization start
battery0: battery initialization done, tried 1 times
battery1: battery initialization failed, giving up

Looks right to me. Greping for acpi or fail doesn't yield anything

There is a bunch of errors during shutdown, I have a dmesg with verbose
boot, shutdown and normal boot prepared, for whoever wants to look at it.

> Someone then worked around some EC issue using mode
> rather than relying on notifications, I vaguely recall.  You said then
> you run only one battery, so hw.acpi.battery.units is also still wrong?

Yes, it's wrong. There is an option to swap out the optical drive for a
battery, I think. But I still have my optical drive.

>   > >  Are you
>   > > running the latest current?  I haven't updated in a while, so perhaps
>   > > the issue has been resolved...
>   >
>   > Nay, I stick to the RELENG_ branches. I'll switch to RELENG_10
>   > shortly before a 10.0 release.
> If there's any indication of ACPI errors on boot (or later) this would
> be worthy of a PR, especially as you're not alone in this, on HP gear.
> I suppose you've checked HP for any more recent BIOS &/or EC updates?

The bios version reported by dmidecode matches the latest download
from HP:
         Vendor: Hewlett-Packard
         Version: 68DDU Ver. F.15
         Release Date: 01/15/2009


A: Because it fouls the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on usenet and in e-mail?

More information about the freebsd-stable mailing list